$re = '/<p(?:(?!<|>).)*>((?:(?!<p|<\/p>).|\s)*)<\/p>/m';
$str = '</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;"> Tên công ty: {company_name}
</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;"> (#)Địa chỉ: {company_address}</span></p>
<p style="text-align: justify;"> (#)<span style="font-size: 14px;">{company_branch}</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;"> </span> (#)<span style="font-size: 14px;">{company_email}</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;"> </span> (#)<span style="font-size: 14px;">{company_phone1}</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;"> </span> (#)<span style="font-size: 14px;">{company_website}</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;"> {company_tax_code}</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);