const regex = /^GRP-[0-9]+\s(FIX|CHANGE|HOTFIX|FEATURE)\s(CORE|SHARED|ADM|CSR|BUS|OTHER)\s-\s(?=[^a-zA-Z0-9\n]*[a-zA-Z0-9])(?:\([^()\n]*\)\s:\s)?[^()\n]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^GRP-[0-9]+\\s(FIX|CHANGE|HOTFIX|FEATURE)\\s(CORE|SHARED|ADM|CSR|BUS|OTHER)\\s-\\s(?=[^a-zA-Z0-9\\n]*[a-zA-Z0-9])(?:\\([^()\\n]*\\)\\s:\\s)?[^()\\n]*$', 'gm')
const str = `GRP-0888 FIX OTHER - (jest.config.js) : Fix testMatch option issue
GRP-0888 FIX OTHER - Fix testMatch option issue
GRP-0988 FIX CORE - (Some change)
GRP-0988 FIX CORE - (Some change) - Some description
GRP-0988 FIX CORE - (
GRP-0988 FIX CORE - ()
GRP-0988 FIX CORE - (Some change
GRP-0988 FIX CORE - Some change)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}