use strict;
my $str = 'GRP-0888 FIX OTHER - (jest.config.js) : Fix testMatch option issue
GRP-0888 FIX OTHER - Fix testMatch option issue
GRP-0988 FIX CORE - (Some change)
GRP-0988 FIX CORE - (Some change) - Some description
GRP-0988 FIX CORE - (
GRP-0988 FIX CORE - ()
GRP-0988 FIX CORE - (Some change
GRP-0988 FIX CORE - Some change)';
my $regex = qr/^GRP-[0-9]+\s(FIX|CHANGE|HOTFIX|FEATURE)\s(CORE|SHARED|ADM|CSR|BUS|OTHER)\s-\s(?=[^a-zA-Z0-9\n]*[a-zA-Z0-9])(?:\([^()\n]*\)\s:\s)?[^()\n]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}