$re = '/(?:\\\\+|\/+)/m';
$str = 'H\\\\\\\\\\\\\\\\\\\\ello///Wo\\\\rld\\!////';
$subst = "\\";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;