re = /(?:\\+|\/+)/m
str = 'H\\\\\\\\\\\\\\\\\\\\ello///Wo\\\\rld\\!////'
subst = '\\\\'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result