using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[monitor[^\]]+\][^\[]?)(ignoreOlderThan\s?=\s?[0-9]+\w)([^\[]+?ignoreOlderThan\s?=\s?[0-9]+\w)([^\[]+)?";
string input = @"[default]host = 10.2.2.15[monitor://apath]ignoreOlderThan = 14dindex=testsourcetype=whateverignoreOlderThan = 30d[monitor://truck]ignoreOlderThan = 14d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}