re = /(\[monitor[^\]]+\][^\[]?)(ignoreOlderThan\s?=\s?[0-9]+\w)([^\[]+?ignoreOlderThan\s?=\s?[0-9]+\w)([^\[]+)?/m
str = '[default]host = 10.2.2.15[monitor://apath]ignoreOlderThan = 14dindex=testsourcetype=whateverignoreOlderThan = 30d[monitor://truck]ignoreOlderThan = 14d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end