using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+) <\/";
string input = @"</ span> <br> <i class = ""material-icons"" style = ""position: relative; top: 2px;""> избранное </ i> <span style = ""font-weight: 600;""> 15 </ span> нравится </ p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}