$re = '/(\d+) <\//m';
$str = '</ span> <br> <i class = "material-icons" style = "position: relative; top: 2px;"> избранное </ i> <span style = "font-weight: 600;"> 15 </ span> нравится </ p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);