import re
regex = re.compile(r"(\d+) <\/", flags=re.MULTILINE)
test_str = "</ span> <br> <i class = \"material-icons\" style = \"position: relative; top: 2px;\"> избранное </ i> <span style = \"font-weight: 600;\"> 15 </ span> нравится </ p>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")