// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+) <\/").unwrap();
let string = "</ span> <br> <i class = \"material-icons\" style = \"position: relative; top: 2px;\"> избранное </ i> <span style = \"font-weight: 600;\"> 15 </ span> нравится </ p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}