using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\G(?(?=^)\^?((?:(?2)\|)*(?![^|)$])|(?:(?2)\|)*?(?=(?<![^^|(])((\w|\((?:\||(?3))*\))*(?![^|$)]))(?=(.*)))(?!(?:(?=\2((?(5)\5\|(?2)|)))){1,50}?(?=\2\5\|(?2)(.*))(?:(?=.*?(?=\4$)\5\|((?(7)\7)((?:\((?1)|\|(?2)|\))*?\w)(?=.*\6$)))(?8)(?=.*\4$))*+(?!(?8)(?=.*\4$)))))(?8)";
string input = @"^WSSEESWWWNW(S|NENNEEEENN(ESSSSW(NWSW|SSEN)|WSWWN(E|WWS(E|SS))))$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}