$re = '/\G(?(?=^)\^?((?:(?2)\|)*(?![^|)$])|(?:(?2)\|)*?(?=(?<![^^|(])((\w|\((?:\||(?3))*\))*(?![^|$)]))(?=(.*)))(?!(?:(?=\2((?(5)\5\|(?2)|)))){1,50}?(?=\2\5\|(?2)(.*))(?:(?=.*?(?=\4$)\5\|((?(7)\7)((?:\((?1)|\|(?2)|\))*?\w)(?=.*\6$)))(?8)(?=.*\4$))*+(?!(?8)(?=.*\4$)))))(?8)/m';
$str = '^WSSEESWWWNW(S|NENNEEEENN(ESSSSW(NWSW|SSEN)|WSWWN(E|WWS(E|SS))))$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);