use strict;
my $str = '^WSSEESWWWNW(S|NENNEEEENN(ESSSSW(NWSW|SSEN)|WSWWN(E|WWS(E|SS))))$';
my $regex = qr/\G(?(?=^)\^?((?:(?2)\|)*(?![^|)$])|(?:(?2)\|)*?(?=(?<![^^|(])((\w|\((?:\||(?3))*\))*(?![^|$)]))(?=(.*)))(?!(?:(?=\2((?(5)\5\|(?2)|)))){1,50}?(?=\2\5\|(?2)(.*))(?:(?=.*?(?=\4$)\5\|((?(7)\7)((?:\((?1)|\|(?2)|\))*?\w)(?=.*\6$)))(?8)(?=.*\4$))*+(?!(?8)(?=.*\4$)))))(?8)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}