import Foundation
let pattern = #"\G(?(?=^)\^?((?:(?2)\|)*(?![^|)$])|(?:(?2)\|)*?(?=(?<![^^|(])((\w|\((?:\||(?3))*\))*(?![^|$)]))(?=(.*)))(?!(?:(?=\2((?(5)\5\|(?2)|)))){1,50}?(?=\2\5\|(?2)(.*))(?:(?=.*?(?=\4$)\5\|((?(7)\7)((?:\((?1)|\|(?2)|\))*?\w)(?=.*\6$)))(?8)(?=.*\4$))*+(?!(?8)(?=.*\4$)))))(?8)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"^WSSEESWWWNW(S|NENNEEEENN(ESSSSW(NWSW|SSEN)|WSWWN(E|WWS(E|SS))))$"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)