#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]\d{0,3}|[1-5]\d{4}|6[0-4]\d{3}|65[0-4]\d{2}|655[0-2]\d|6553[1-5])$"
Local $sString = "1" & @CRLF & _
"1234" & @CRLF & _
"9999" & @CRLF & _
"12345" & @CRLF & _
"59999" & @CRLF & _
"64999" & @CRLF & _
"65499" & @CRLF & _
"65535" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"0" & @CRLF & _
"01" & @CRLF & _
"123456" & @CRLF & _
"65536" & @CRLF & _
" 1234" & @CRLF & _
"-23" & @CRLF & _
"234-" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")