import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]\\d{0,3}|[1-5]\\d{4}|6[0-4]\\d{3}|65[0-4]\\d{2}|655[0-2]\\d|6553[1-5])$";
final String string = "1\n"
+ "1234\n"
+ "9999\n"
+ "12345\n"
+ "59999\n"
+ "64999\n"
+ "65499\n"
+ "65535\n\n\n"
+ "0\n"
+ "01\n"
+ "123456\n"
+ "65536\n"
+ " 1234\n"
+ "-23\n"
+ "234-\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}