re = /^([1-9]\d{0,3}|[1-5]\d{4}|6[0-4]\d{3}|65[0-4]\d{2}|655[0-2]\d|6553[1-5])$/m
str = '1
1234
9999
12345
59999
64999
65499
65535
0
01
123456
65536
1234
-23
234-
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end