import re
regex = re.compile(r"^([1-9]\d{0,3}|[1-5]\d{4}|6[0-4]\d{3}|65[0-4]\d{2}|655[0-2]\d|6553[1-5])$", flags=re.MULTILINE)
test_str = ("1\n"
"1234\n"
"9999\n"
"12345\n"
"59999\n"
"64999\n"
"65499\n"
"65535\n\n\n"
"0\n"
"01\n"
"123456\n"
"65536\n"
" 1234\n"
"-23\n"
"234-\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")