package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+375|80) \((29|25|44|33|17)\) [0-9]{3}-[0-9]{2}-[0-9]{2}$`)
var str = `+375 (33) 999-99-99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}