const regex = /^(\+375|80) \((29|25|44|33|17)\) [0-9]{3}-[0-9]{2}-[0-9]{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+375|80) \\((29|25|44|33|17)\\) [0-9]{3}-[0-9]{2}-[0-9]{2}$', 'gm')
const str = `+375 (33) 999-99-99`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}