re = /^(\+375|80) \((29|25|44|33|17)\) [0-9]{3}-[0-9]{2}-[0-9]{2}$/m
str = '+375 (33) 999-99-99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end