import re
regex = re.compile(r"<block.*?Name[\s|\t]+data3[\s|\t]+.*?<\/block>", flags=re.MULTILINE | re.DOTALL)
test_str = ("<block>\n"
"Name data1\n"
"Spec 36\n"
"</block>\n"
"<block>\n"
"Name data2\n"
"Spec 22\n"
"</block>\n"
"<block>\n"
"Name data3\n"
"Spec 56\n"
"</block>\n"
"<block>\n"
"Name data4\n"
"Spec 41\n"
"</block>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")