#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!^\s)(?<=[\((\,\s?)])(FoX::)?Image\s?\*"
Local $sString = ", Image *" & @CRLF & _
",Image *" & @CRLF & _
"(Image *" & @CRLF & _
"( Image *" & @CRLF & _
", FoX::Image *" & @CRLF & _
",FoX::Image *" & @CRLF & _
"(FoX::Image *" & @CRLF & _
"( FoX::Image *" & @CRLF & _
"/* [retval][out] */ ICscImage **pVal) = 0;" & @CRLF & _
" Image* pImage = Image::Create();" & @CRLF & _
" Image* pImage = Image::Create();"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")