use strict;
my $str = ', Image *
,Image *
(Image *
( Image *
, FoX::Image *
,FoX::Image *
(FoX::Image *
( FoX::Image *
/* [retval][out] */ ICscImage **pVal) = 0;
Image* pImage = Image::Create();
Image* pImage = Image::Create();';
my $regex = qr/(?<!^\s)(?<=[\((\,\s?)])(FoX::)?Image\s?\*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}