const regex = /^s?([\/|@#])(?:(?!\1).)+\1(?:(?!\1).)*\1(?:i|(?:gi?|ig)(\1\d{1,2})?)?$
/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^s?([\\\/|@#])(?:(?!\\1).)+\\1(?:(?!\\1).)*\\1(?:i|(?:gi?|ig)(\\1\\d{1,2})?)?$
', 'mg')
const str = `should match:
/.//
|.||
s/.//
/.//g
/.//i
/././gi
/one-or-more/anything/
/one-or-more/anything/g/3
/one-or-more/anything/i
/one-or-more/anything/gi/99
s/one-or-more/anything/g/4
s/one-or-more/anything/i
s/one-or-more/anything/gi/54
s|.||
|.||g
|.||i
|.|.|gi
|one-or-more|anything|
|one-or-more|anything|g|3
|one-or-more|anything|i
|one-or-more|anything|gi|99
s|one-or-more|anything|g|4
s|one-or-more|anything|i
s|one-or-more|anything|gi|54
should not match:
s/one-or-more/anything/33
s|one-or-more|anything|33
/./
|.|
s|one-or-more|anything|gi|3333
s/one-or-more/anything/gi/3333
/.///
s/.///
s/././/
/anything/anything/anything/anything/
s/anything/anything/anything/
s/anything/anything/anything/g
s/anything/anything/anything/i
s/anything/anything/anything/gi
/anything/anything/anything/gi
/anything/anything/anything/g
/anything/anything/anything/i
|.|||
s|.|||
s|.|.||
|anything|anything|anything|anything|
s|anything|anything|anything|
s|anything|anything|anything|g
s|anything|anything|anything|i
s|anything|anything|anything|gi
|anything|anything|anything|gi
|anything|anything|anything|g
|anything|anything|anything|i`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}