use strict;
my $str = 'should match:
/.//
|.||
s/.//
/.//g
/.//i
/././gi
/one-or-more/anything/
/one-or-more/anything/g/3
/one-or-more/anything/i
/one-or-more/anything/gi/99
s/one-or-more/anything/g/4
s/one-or-more/anything/i
s/one-or-more/anything/gi/54
s|.||
|.||g
|.||i
|.|.|gi
|one-or-more|anything|
|one-or-more|anything|g|3
|one-or-more|anything|i
|one-or-more|anything|gi|99
s|one-or-more|anything|g|4
s|one-or-more|anything|i
s|one-or-more|anything|gi|54
should not match:
s/one-or-more/anything/33
s|one-or-more|anything|33
/./
|.|
s|one-or-more|anything|gi|3333
s/one-or-more/anything/gi/3333
/.///
s/.///
s/././/
/anything/anything/anything/anything/
s/anything/anything/anything/
s/anything/anything/anything/g
s/anything/anything/anything/i
s/anything/anything/anything/gi
/anything/anything/anything/gi
/anything/anything/anything/g
/anything/anything/anything/i
|.|||
s|.|||
s|.|.||
|anything|anything|anything|anything|
s|anything|anything|anything|
s|anything|anything|anything|g
s|anything|anything|anything|i
s|anything|anything|anything|gi
|anything|anything|anything|gi
|anything|anything|anything|g
|anything|anything|anything|i';
my $regex = qr/^s?([\/|@#])(?:(?!\1).)+\1(?:(?!\1).)*\1(?:i|(?:gi?|ig)(\1\d{1,2})?)?$
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}