import Foundation
let pattern = ##"""
^s?([\/|@#])(?:(?!\1).)+\1(?:(?!\1).)*\1(?:i|(?:gi?|ig)(\1\d{1,2})?)?$
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
should match:
/.//
|.||
s/.//
/.//g
/.//i
/././gi
/one-or-more/anything/
/one-or-more/anything/g/3
/one-or-more/anything/i
/one-or-more/anything/gi/99
s/one-or-more/anything/g/4
s/one-or-more/anything/i
s/one-or-more/anything/gi/54
s|.||
|.||g
|.||i
|.|.|gi
|one-or-more|anything|
|one-or-more|anything|g|3
|one-or-more|anything|i
|one-or-more|anything|gi|99
s|one-or-more|anything|g|4
s|one-or-more|anything|i
s|one-or-more|anything|gi|54
should not match:
s/one-or-more/anything/33
s|one-or-more|anything|33
/./
|.|
s|one-or-more|anything|gi|3333
s/one-or-more/anything/gi/3333
/.///
s/.///
s/././/
/anything/anything/anything/anything/
s/anything/anything/anything/
s/anything/anything/anything/g
s/anything/anything/anything/i
s/anything/anything/anything/gi
/anything/anything/anything/gi
/anything/anything/anything/g
/anything/anything/anything/i
|.|||
s|.|||
s|.|.||
|anything|anything|anything|anything|
s|anything|anything|anything|
s|anything|anything|anything|g
s|anything|anything|anything|i
s|anything|anything|anything|gi
|anything|anything|anything|gi
|anything|anything|anything|g
|anything|anything|anything|i
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)