$re = '/^s?([\/|@#])(?:(?!\1).)+\1(?:(?!\1).)*\1(?:i|(?:gi?|ig)(\1\d{1,2})?)?$
/m';
$str = 'should match:
/.//
|.||
s/.//
/.//g
/.//i
/././gi
/one-or-more/anything/
/one-or-more/anything/g/3
/one-or-more/anything/i
/one-or-more/anything/gi/99
s/one-or-more/anything/g/4
s/one-or-more/anything/i
s/one-or-more/anything/gi/54
s|.||
|.||g
|.||i
|.|.|gi
|one-or-more|anything|
|one-or-more|anything|g|3
|one-or-more|anything|i
|one-or-more|anything|gi|99
s|one-or-more|anything|g|4
s|one-or-more|anything|i
s|one-or-more|anything|gi|54
should not match:
s/one-or-more/anything/33
s|one-or-more|anything|33
/./
|.|
s|one-or-more|anything|gi|3333
s/one-or-more/anything/gi/3333
/.///
s/.///
s/././/
/anything/anything/anything/anything/
s/anything/anything/anything/
s/anything/anything/anything/g
s/anything/anything/anything/i
s/anything/anything/anything/gi
/anything/anything/anything/gi
/anything/anything/anything/g
/anything/anything/anything/i
|.|||
s|.|||
s|.|.||
|anything|anything|anything|anything|
s|anything|anything|anything|
s|anything|anything|anything|g
s|anything|anything|anything|i
s|anything|anything|anything|gi
|anything|anything|anything|gi
|anything|anything|anything|g
|anything|anything|anything|i';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);