const regex = new RegExp('(?=[A-Z-\\/_]{0,}[0-9]{3,})[A-Z0-9-\\/_]{7,}', 'img')
const str = `Te poniższe bym chciał:
ZOC1050056
23639583
GL20/11878/17
20700246365_1
WR50/11349/17
PL201709120448
pl2017072600414
1054332/1133787
H201709201932-01
143392/DLS/17
KO/455/17
12222222/22
a to już false positives:
66565
bardzodlugieslowo
niechcetegoo?
2/zamalocyfer
32tubysietez przydalo wiecej`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}