use strict;
my $str = ' 12/27/17
8:24:49.599 AM
1514363089599 Groupon I will do my best to help you, please tell me more about the issue you are having.
host =instance-1 source =/var/www/html/backend/log_chat/conversation.log
12/27/17
8:24:49.599 AM
1514363089599 user i need help
host =instance-1 source =/var/www/html/backend/log_chat/conversation.log
12/27/17
8:24:49.599 AM
1514363089599 Groupon Hello! Thank you for contacting Groupon
host =instance-1 source =/var/www/html/backend/log_chat/conversation.log';
my $regex = qr/(?ms)\d+\/\d+\/\d+\s+\d+:\d+:\d+\.\d+\s\w+\s+(?<session_io>\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}