re = /(?ms)\d+\/\d+\/\d+\s+\d+:\d+:\d+\.\d+\s\w+\s+(?<session_io>\d+)/
str = ' 12/27/17
8:24:49.599 AM
1514363089599 Groupon I will do my best to help you, please tell me more about the issue you are having.
host =instance-1 source =/var/www/html/backend/log_chat/conversation.log
12/27/17
8:24:49.599 AM
1514363089599 user i need help
host =instance-1 source =/var/www/html/backend/log_chat/conversation.log
12/27/17
8:24:49.599 AM
1514363089599 Groupon Hello! Thank you for contacting Groupon
host =instance-1 source =/var/www/html/backend/log_chat/conversation.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end