import Foundation
let pattern = #"(?ms)\d+\/\d+\/\d+\s+\d+:\d+:\d+\.\d+\s\w+\s+(?<session_io>\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
12/27/17
8:24:49.599 AM
1514363089599 Groupon I will do my best to help you, please tell me more about the issue you are having.
host =instance-1 source =/var/www/html/backend/log_chat/conversation.log
12/27/17
8:24:49.599 AM
1514363089599 user i need help
host =instance-1 source =/var/www/html/backend/log_chat/conversation.log
12/27/17
8:24:49.599 AM
1514363089599 Groupon Hello! Thank you for contacting Groupon
host =instance-1 source =/var/www/html/backend/log_chat/conversation.log
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)