// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)\d+\/\d+\/\d+\s+\d+:\d+:\d+\.\d+\s\w+\s+(?<session_io>\d+)").unwrap();
let string = " 12/27/17
8:24:49.599 AM
1514363089599 Groupon I will do my best to help you, please tell me more about the issue you are having.
host =instance-1 source =/var/www/html/backend/log_chat/conversation.log
12/27/17
8:24:49.599 AM
1514363089599 user i need help
host =instance-1 source =/var/www/html/backend/log_chat/conversation.log
12/27/17
8:24:49.599 AM
1514363089599 Groupon Hello! Thank you for contacting Groupon
host =instance-1 source =/var/www/html/backend/log_chat/conversation.log";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}