#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m);\K(\s*.*?)(\s*\S+)$"
Local $sString = "CEyYBUoAfhL.txt; "CEyYBUoAfhL-MI2.jpg" "CEyYBUoAfhL-MI3.jpg" "CEyYBUoAfhL-MI4.jpg" "CEyYBUoAfhL-MI5.jpg" "CEyYBUoAfhL-MI6.jpg" "CEyYBUoAfhL.jpg"" & @CRLF & _
"CEyYBUoAfhL.txt; "CEyYBUoAfhL-MI2.jpg" "CEyYBUoAfhL-MI3.jpg" "CEyYBUoAfhL.jpg"" & @CRLF & _
"CAjaBo1AL-9.txt; "CAjaBo1AL-9-MI2.jpg" "CAjaBo1AL-9-MI3.jpg" "CAjaBo1AL-9-MI4.jpg" "CAjaBo1AL-9.jpg""
Local $sSubst = "\2\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)