const regex = /;\K(\s*.*?)(\s*\S+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(';\\K(\\s*.*?)(\\s*\\S+)$', 'gm')
const str = `CEyYBUoAfhL.txt; "CEyYBUoAfhL-MI2.jpg" "CEyYBUoAfhL-MI3.jpg" "CEyYBUoAfhL-MI4.jpg" "CEyYBUoAfhL-MI5.jpg" "CEyYBUoAfhL-MI6.jpg" "CEyYBUoAfhL.jpg"
CEyYBUoAfhL.txt; "CEyYBUoAfhL-MI2.jpg" "CEyYBUoAfhL-MI3.jpg" "CEyYBUoAfhL.jpg"
CAjaBo1AL-9.txt; "CAjaBo1AL-9-MI2.jpg" "CAjaBo1AL-9-MI3.jpg" "CAjaBo1AL-9-MI4.jpg" "CAjaBo1AL-9.jpg"`;
const subst = `\2\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);