import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ";\\K(\\s*.*?)(\\s*\\S+)$";
final String string = "CEyYBUoAfhL.txt; \"CEyYBUoAfhL-MI2.jpg\" \"CEyYBUoAfhL-MI3.jpg\" \"CEyYBUoAfhL-MI4.jpg\" \"CEyYBUoAfhL-MI5.jpg\" \"CEyYBUoAfhL-MI6.jpg\" \"CEyYBUoAfhL.jpg\"\n"
+ "CEyYBUoAfhL.txt; \"CEyYBUoAfhL-MI2.jpg\" \"CEyYBUoAfhL-MI3.jpg\" \"CEyYBUoAfhL.jpg\"\n"
+ "CAjaBo1AL-9.txt; \"CAjaBo1AL-9-MI2.jpg\" \"CAjaBo1AL-9-MI3.jpg\" \"CAjaBo1AL-9-MI4.jpg\" \"CAjaBo1AL-9.jpg\"";
final String subst = "\\2\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}