re = /;\K(\s*.*?)(\s*\S+)$/m
str = 'CEyYBUoAfhL.txt; "CEyYBUoAfhL-MI2.jpg" "CEyYBUoAfhL-MI3.jpg" "CEyYBUoAfhL-MI4.jpg" "CEyYBUoAfhL-MI5.jpg" "CEyYBUoAfhL-MI6.jpg" "CEyYBUoAfhL.jpg"
CEyYBUoAfhL.txt; "CEyYBUoAfhL-MI2.jpg" "CEyYBUoAfhL-MI3.jpg" "CEyYBUoAfhL.jpg"
CAjaBo1AL-9.txt; "CAjaBo1AL-9-MI2.jpg" "CAjaBo1AL-9-MI3.jpg" "CAjaBo1AL-9-MI4.jpg" "CAjaBo1AL-9.jpg"'
subst = '\\2\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result