#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?=foo.*_.+)(?<!\").*?\((?<!\"))"
Local $sString = " CheckBarStatus(appHandle, "fooBarApp_Lvds_init", fooBarApp_Lvds_init(LVDS_CORE_RESOURCE, VI_TRUE, NULL, &appHandle), FUNCTION_CHECK_STOP_ON_FAIL);" & @CRLF & _
"output = fooBar_Config_GetInstrumentCount(&instrumentCount);" & @CRLF & _
"output = fooBar_init(resourceName, VI_FALSE, VI_TRUE, &vi);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")