use strict;
my $str = ' CheckBarStatus(appHandle, "fooBarApp_Lvds_init", fooBarApp_Lvds_init(LVDS_CORE_RESOURCE, VI_TRUE, NULL, &appHandle), FUNCTION_CHECK_STOP_ON_FAIL);
output = fooBar_Config_GetInstrumentCount(&instrumentCount);
output = fooBar_init(resourceName, VI_FALSE, VI_TRUE, &vi);';
my $regex = qr/((?=foo.*_.+)(?<!\").*?\((?<!\"))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}