import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?=foo.*_.+)(?<!\\\").*?\\((?<!\\\"))";
final String string = " CheckBarStatus(appHandle, \"fooBarApp_Lvds_init\", fooBarApp_Lvds_init(LVDS_CORE_RESOURCE, VI_TRUE, NULL, &appHandle), FUNCTION_CHECK_STOP_ON_FAIL);\n"
+ "output = fooBar_Config_GetInstrumentCount(&instrumentCount);\n"
+ "output = fooBar_init(resourceName, VI_FALSE, VI_TRUE, &vi);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}