const regex = new RegExp('((?=foo.*_.+)(?<!\\").*?\\((?<!\\"))', 'g')
const str = ` CheckBarStatus(appHandle, "fooBarApp_Lvds_init", fooBarApp_Lvds_init(LVDS_CORE_RESOURCE, VI_TRUE, NULL, &appHandle), FUNCTION_CHECK_STOP_ON_FAIL);
output = fooBar_Config_GetInstrumentCount(&instrumentCount);
output = fooBar_init(resourceName, VI_FALSE, VI_TRUE, &vi);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}