using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(i=Transactional>\r?\n)(?!STYLE)(.*\r?\n.*)";
string input = @"<http://link.ORDERACK...&i=Transactional>
STYLE: 0043
QTY: 11
<http://link.ORDERACK...&i=Transactional>
Striped
Cotton Rugby Short RED
<http://link.ORDERACK...&i=Transactional>
STYLE: 0042
QTY: 10
<http://link.ORDERACK...&i=Transactional>
Striped
Cotton Polo Short";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}