re = /(i=Transactional>\r?\n)(?!STYLE)(.*\r?\n.*)/m
str = '<http://link.ORDERACK...&i=Transactional>
STYLE: 0043
QTY: 11
<http://link.ORDERACK...&i=Transactional>
Striped
Cotton Rugby Short RED
<http://link.ORDERACK...&i=Transactional>
STYLE: 0042
QTY: 10
<http://link.ORDERACK...&i=Transactional>
Striped
Cotton Polo Short'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end