use strict;
my $str = '<http://link.ORDERACK...&i=Transactional>
STYLE: 0043
QTY: 11
<http://link.ORDERACK...&i=Transactional>
Striped
Cotton Rugby Short RED
<http://link.ORDERACK...&i=Transactional>
STYLE: 0042
QTY: 10
<http://link.ORDERACK...&i=Transactional>
Striped
Cotton Polo Short';
my $regex = qr/(i=Transactional>\r?\n)(?!STYLE)(.*\r?\n.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}