const regex = /(i=Transactional>\r?\n)(?!STYLE)(.*\r?\n.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(i=Transactional>\\r?\\n)(?!STYLE)(.*\\r?\\n.*)', 'gm')
const str = `<http://link.ORDERACK...&i=Transactional>
STYLE: 0043
QTY: 11
<http://link.ORDERACK...&i=Transactional>
Striped
Cotton Rugby Short RED
<http://link.ORDERACK...&i=Transactional>
STYLE: 0042
QTY: 10
<http://link.ORDERACK...&i=Transactional>
Striped
Cotton Polo Short`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}