#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[2-9]|[1-9]\d+$"
Local $sString = "2" & @CRLF & _
"3" & @CRLF & _
"10" & @CRLF & _
"11" & @CRLF & _
"5000" & @CRLF & _
"100001" & @CRLF & _
"1" & @CRLF & _
"-1" & @CRLF & _
"-8" & @CRLF & _
"0" & @CRLF & _
"a" & @CRLF & _
"blbl" & @CRLF & _
"100100" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")