import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[2-9]|[1-9]\\d+$";
final String string = "2\n"
+ "3\n"
+ "10\n"
+ "11\n"
+ "5000\n"
+ "100001\n"
+ "1\n"
+ "-1\n"
+ "-8\n"
+ "0\n"
+ "a\n"
+ "blbl\n"
+ "100100\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}