package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[2-9]|[1-9]\d+$`)
var str = `2
3
10
11
5000
100001
1
-1
-8
0
a
blbl
100100
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}