const regex = /^(?:(\d{1,3}\.?(?:\d{1,3}\.?)*)?) ?([^\W\d]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(\\d{1,3}\\.?(?:\\d{1,3}\\.?)*)?) ?([^\\W\\d]+)', 'gm')
const str = `section
1 section
2. section
2.1 subsection
2.1.1 subsection
2.1.1. subsection
1111
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}